Configuring Windows Media Center to work as it should – Can’t get .mp4 and .avi video’s to play in MCE

I’m configuring Windows Media Center on my Windows 7 laptop to stream videos from my NAS (http://www.netgear.com/stora).
I want to make sure everything work as I expect it before I start to order parts for my HTPC (http://smnbss.spaces.live.com/blog/cns!A117AA5E007A0648!1996.entry).

The media center easily recognize my Stora, and I was able to add the shared folders to the MCE configuration, but I couldn’t find most of the movies I had shared, just a couple of them. It turned out it’s a problem with the way the avi files are perceived from windows 7.

The solution was to merge this file into the windows registry

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT.mpeg]
“Content Type”=”video/mpeg”
“PerceivedType”=”video”

[HKEY_CLASSES_ROOT.mpg]
“Content Type”=”video/mpeg”
“PerceivedType”=”video”

[HKEY_CLASSES_ROOT.avi]
“Content Type”=”video/avi”
“PerceivedType”=”video”

[HKEY_CLASSES_ROOT.m4v]
“Content Type”=”video/mp4”
“PerceivedType”=”video”

[HKEY_CLASSES_ROOT.asf]
“Content Type”=”video/x-ms-asf”
“PerceivedType”=”video”

[HKEY_CLASSES_ROOT.mov]
“Content Type”=”video/quicktime”
“PerceivedType”=”video”

[HKEY_CLASSES_ROOT.MPE]
“Content Type”=”video/mpeg”
“PerceivedType”=”video”

[HKEY_CLASSES_ROOT.wmv]
“Content Type”=”video/x-ms-wmv”
“PerceivedType”=”video”

Advertisements

One thought on “Configuring Windows Media Center to work as it should – Can’t get .mp4 and .avi video’s to play in MCE

  1. THANKS for providing the only working solution, and at an unexpected site.

    But there are some small errors, e g for AVI it goes like this:

    [HKEY_CLASSES_ROOT\.avi]
    @=”mplayerc.avi”
    “PerceivedType”=”video”
    “Content Type”=”video/avi”

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s